Insimenator.org
August 12, 2020, 08:29:07 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Insim's annual Donation Drive is on! Click here for info and to toss some money our way.
 
  Home   Forum   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: Custom mesh looks weird in game? :SOLVED:  (Read 4035 times)
0 Members and 1 Guest are viewing this topic.
Dullahan
Lady of the Hunt
Loot Looker
****
Gender: Female
Posts: 951


Ok, flex more ; )


View Profile WWW
« on: May 02, 2011, 03:13:47 pm »

Hello, I am making my first object meshes. I started with some models that someone let me use, and started modifying. Well, I made them and they look all good in milkshape and simPE, but then in game, they are mostly see-through when you look at them from the front, but look fine from the side.



But then in wings 3d and milkshape, it looks good and solid


I'm not really sure where I went wrong, so if someone could help, I'd be most appreciative...
« Last Edit: May 05, 2011, 03:06:58 pm by jinxismycat » Logged

Theraven
The Bird Queen
Super Mod
*****
Gender: Female
Posts: 5015


Permanently distracted by Something Shiny


View Profile WWW
« Reply #1 on: May 02, 2011, 03:21:16 pm »

If you look at the TXMT resource/material definition, there is a box in the plugin view where you'll see several lines of text. One of them (near the top) says something like "alpha blend:" and either "none" or "blend". The "blend" variant can cause wonky-looking meshes, particularly the see-through problem (I've had my share of those). If that's the case, change this line to "none". Especially problematic if you've got Pets installed (I think this problem followed the Pets EP, as most accessories using blend are wonky with Pets installed).

For meshes supposed to be alpha-editable (especially with see-through textures) you've got to work around this, as they depend on the blend function to work. I've come up with a few ways to do that, but none of those are 100% optimal...
« Last Edit: May 02, 2011, 03:27:14 pm by Theraven » Logged

My site:

Little Fire Burning - Chapter 85 out

~Life isn't about waiting for the storm to pass. It's about learning to dance in the rain~
Dullahan
Lady of the Hunt
Loot Looker
****
Gender: Female
Posts: 951


Ok, flex more ; )


View Profile WWW
« Reply #2 on: May 02, 2011, 07:57:09 pm »

It is already set on none. :[
Logged

Theraven
The Bird Queen
Super Mod
*****
Gender: Female
Posts: 5015


Permanently distracted by Something Shiny


View Profile WWW
« Reply #3 on: May 03, 2011, 12:19:36 am »

I'm still almost convinced there's something wrong in the texture bit.
Which object did you clone, and have you changed anything besides the GUID, the texture picture, the GMDC and the object description?

Could you upload the file? It would be easier to figure out what's the problem then.
Logged

My site:

Little Fire Burning - Chapter 85 out

~Life isn't about waiting for the storm to pass. It's about learning to dance in the rain~
Dullahan
Lady of the Hunt
Loot Looker
****
Gender: Female
Posts: 951


Ok, flex more ; )


View Profile WWW
« Reply #4 on: May 03, 2011, 10:05:34 am »

I cloned "The gray woman" from Nightlife. Not that I am aware of. I just did the usual stuff for making new objects.
Heres the package file:
http://www.mediafire.com/?0xqppt033hzw858
Logged

Theraven
The Bird Queen
Super Mod
*****
Gender: Female
Posts: 5015


Permanently distracted by Something Shiny


View Profile WWW
« Reply #5 on: May 03, 2011, 11:36:36 am »

The mesh is inside-out in both SimPE and Milkshape, at least for me. Seems like the mesh normals are turned inside-out (polygon backsides are invisible, and creates this look of the mesh since only the inside shows).

Never seen it as a mesh problem in SimPE. I sometimes get it with blend-textures ingame, but not with the actual mesh. No idea how to fix it in Milkshape, and it shows up even more wonky in my other mesh program (it has which seems to hate triangular-poly meshes like obj meshes with a passion)

Did you make the mesh from scratch, or did you use a downloaded mesh or a mesh from another game? Downloaded meshes or game meshes sometimes tend to cause strange problems.

You didn't by any chance have "auto smooth" enabled?

Right-clicking in the 3D_window and choosing "draw backfaces" seems to turn it the right way in Milkshape. Not entirely sure if it will help for the mesh, though... Doesn't look like it changed anything.

---

One thing sort of worked.
In MIlkshape, mark the mesh, and choose "reverse vertex order" from the face menu. Then choose "align normals" from the vertex menu. The smoothing might be a bit weird, and it might refuse to be edited again, but at least the mesh turned the right way.
Set the 3D screen to "smooth shaded", so you see what is happening.
« Last Edit: May 03, 2011, 11:53:45 am by Theraven » Logged

My site:

Little Fire Burning - Chapter 85 out

~Life isn't about waiting for the storm to pass. It's about learning to dance in the rain~
Dullahan
Lady of the Hunt
Loot Looker
****
Gender: Female
Posts: 951


Ok, flex more ; )


View Profile WWW
« Reply #6 on: May 03, 2011, 12:17:42 pm »

A friend of mine ripped it from Jet Set Radio Future, which is an xbox game. So, what you said makes a lot of sense.
Okay, I will try that and see if it changes anything.

---
Okay, I tried the thing you said, and it looks a whole lot better! It is no longer transparent in game.


There are a few things I need to try and fix like her left sleeve, and the top of the dress, but the rest looks good!

Thanks for your help so far!
« Last Edit: May 03, 2011, 01:05:01 pm by jinxismycat » Logged

Pages: [1]
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.078 seconds with 30 queries.
SimplePortal 2.1.1