Insimenator.org
January 27, 2020, 09:54:11 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: InSim only exists due to the generosity of our awesome community. If you'd like to help out, see this thread and toss some change our way. Thanks!
 
  Home   Forum   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: default sky ETA: Stupid EAxis (please read)  (Read 1114 times)
0 Members and 1 Guest are viewing this topic.
alkaloid
Member

Posts: 298


View Profile WWW
« on: December 29, 2007, 09:53:31 am »

Is the sky you see in the game not called skysphere? I've made a default texture replacement for skysphere, and it's not taking no matter which method I use to construct the package.

This makes me think one of two things is going on:

1. The sky has been coded to resist default replacement.

2. The sky isn't skysphere. Skysphere is then either a lost item, or it's used for something weird, like thumbnail generation.

Has anyone tried this before? Any ideas? Bueller?



ETA: The answer is 2, and possibly also 1. I found the new sky, but, um, check out what a normal-method default replacement did. Normal method for me means only replacing the highest-quality image in a txtr file, and mipmapping the other sizes to point to the big one.

ETA #2: I did a replacement package with the full range of mipmapped images. One side of the sky cube changed. (I should note that it looks like the neighborhood sky and the lot sky are two different things, since one turned green and the other turned pink/tan - the gradient colors I'm using for this). :/ I'm going to check the txmt file list to see if perhaps I missed some. If not, I'm going to scrap this and leave my notes here for anyone else who wants to try this.

ETA #3: OK. I have been up and down the game files, and I cannot find anything that might be the txmt for the sky, or txtrs for the other sides. Everything's either obviously something else, or it was ambiguous and ruled out. Does anyone know how to find the parts of a package when EAxis has named it all sorts of different things?


* lolomg.jpg (79.3 KB, 806x625 - viewed 538 times.)
« Last Edit: December 29, 2007, 04:39:00 pm by alkaloid » Logged

BlooM
Member

Gender: Male
Posts: 2980


View Profile
« Reply #1 on: December 30, 2007, 04:24:14 pm »

Never tried to change it but i do know one thing,
If parts from my default replacements are turning red when testing them it can not find the texture file.
Prolly the linking went wrong.
Logged

No longer active
Pages: [1]
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.098 seconds with 31 queries.
SimplePortal 2.1.1