Insimenator.org
February 08, 2023, 01:03:56 pm *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home   Forum   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: Trouble Installing The Sims 2 on Vista Home Premium 64-bit  (Read 1092 times)
0 Members and 1 Guest are viewing this topic.
ryskia
Member

Posts: 18


View Profile
« on: December 21, 2008, 02:21:04 pm »

Okay, I just received a new laptop and tried installing The Sims on it. It's a Vista Home Premium 64-bit, and I've heard that there are problems installing games on Vista 64-bit (but I was pretty sure they released updates to fix or lessen the problem).

Anyways, I'm using the same discs I had used to install The Sims 2 on my Windows XP, but for some reason it doesn't appear to be installing properly. I couldn't find the EA Games folder in "My Documents" until AFTER I uninstalled the game, and now every time I try to update the game with any of the patches while installing it'll have this message saying there was an error and completely uninstalls. I seriously spent a whole day (11 AM- 5 AM) trying to install this game into my computer. I even reformatted it because I thought it might be a problem with SecuROM.

So, if anyone has the Vista Home Premium 64-bit OS, can you please tell me how did you install it? Did you install it using the default/basic settings or did you install using the "Advanced User" option and put it in My Documents or something? (I have installed The Sims 2 using Advanced User on my XP, so that I could put the game on an external hard drive and I never had a problem up until now!)

Some info on my laptop:
Inter Core 2 duo processor
4 GB RAM
250 GB Hard drive (191GB available)
Windows Vista Home Premium 64-bit
Logged
rwills
Member

Posts: 800


View Profile
« Reply #1 on: December 21, 2008, 06:12:57 pm »

To install on a Vista machine, you must be using either the administrator account or an account with admin privileges enabled.

Scroll down to 'Other Topics' here for a bit more info:

http://thesims2.ea.com/help/detail.php?help_id=281

Also, as it is a duo core machine, take a look here about the possibility of altering the affinity settings in case you have other problems:

http://modthesims2.com/wiki.php?title=Game_Help:Dual_Core_Issues

Also, you didn't mention what graphics card/chipset is installed on the machine. It may not be readily capable of handling the game (or may not be readily capable of handling more than the basic game). Even so, installing any newer or updated drivers for you machine's graphics card is is Good Thing.
Logged
ryskia
Member

Posts: 18


View Profile
« Reply #2 on: December 21, 2008, 07:07:55 pm »

I was able to successfully install it today-- I don't know what happened haha. Thank you!
Logged
Pages: [1]
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.031 seconds with 30 queries.
SimplePortal 2.1.1